M2eclipse updating indexes

Recently I face an strange issue while using Maven in Eclipse via M2Eclipse plugin.

m2eclipse updating indexes-18m2eclipse updating indexes-14

After some trial and error, I realized that this is my brand new workspace and I am running with Eclipse Luna, newest version of Eclipse which I had just downloaded couple days of back.

My first hunch was that Eclipse might not able to connect to Internet, and to verify that I tried connecting Eclipse market place, and boom it was working fine.

This will rebuild repository index for local use, and will help you to quickly add any JAR file dependency in your Maven project.

That's all about how do you fix this problem of Maven not able to search dependencies in Eclipse.

If you know the artifact id and group id you can directly add any dependency but most of us doesn't remember that, what we do is search for that artifact or JAR by typing e.g.

to add JAR file related to Hibernate or Spring Framework you will type hibernate or spring framework in given search bar.

If that file is not download or not exist due to any reason, Maven's dependency search will not work in Eclipse.

That's why you need to check the option "Download repository Index updates on startup".

You can see that Eclipse is updating indexes and it's doing it from Maven central repository,

If you had configured internal nexus repository then it will download from there.

Eclipse was not able to search dependency in Maven central repository.

Tags: , ,